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1 General Information

Read through this operating manual carefully before use and become familiar with the product.
Installation and start-up should not be carried out before reading and understanding this docu-
ment. Keep this manual readily available so that you can reference it as needed.

1.1 What Is the Purpose of this Operating Manual?

This manual serves as an aid for the installation and operation of the product and supports the
technical staff with all operating and maintenance tasks to be performed. Furthermore, this manu-
al is aimed at preventing dangers to life and health of the user and third parties.

1.2 Who Is this Operating Manual Targeted to?

The operating manual provides a code of conduct for personnel tasked with the setup, operation,
maintenance, and repair of gas engines. A certain level of technical knowledge with respect to the
operation of gas engines and basic knowledge of electronic ignition systems are necessary. Per-
sons who are only authorized to operate the gas engine shall be trained by the operating company
and shall be expressly instructed concerning potential hazards.

1.3 Which Symbols Are Used in the Operating Manual?

The following symbols are used in this manual and must be observed:

Example

This symbol indicates examples, which point out necessary handling
steps and techniques. In addition, you receive additional information from
the examples, which will increase your knowledge.

EXAMPLE

Notice

-4 This symbol indicates important notices for the user. Follow these. In ad-
1 dition, this symbol is used for overviews that give you a summary of the
necessary work steps.
NOTICE

Warning

This symbol indicates warnings for possible risks of property damage or
risks to health. Read these warning notices carefully and take the men-
tioned precautionary measures.
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1 General Information

Danger

This symbol indicates warnings for danger to life, especially due to high
voltage. Read these warning notices carefully and take the mentioned
precautionary measures.

DANGER

1.4 Which Abbreviations/Acronyms Are Used in the Operating Manual?
In the operating manual or the user interface, the following abbreviations/acronyms are used.

Abb.
°CRANK

Csv

DetCon

HMI
MIC
Temp-

Scan
USB
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Term

Degree crankshaft

Comma-separated
Values

Detonation Controller

Human-Machine
Interface

MOTORTECH Ignition
Controller

Thermocouple
Scanner

Universal Serial Bus

Description

Data separated by
comma

Explanation

Unit for the rotation angle of the
crankshaft

Text file for storage or ex-
change of structured data

Serves to prevent major engine
damage that can be caused by
knocking combustion.

Interface between a human and
a machine or a computer

Serial connection system to link
a computer to external devices



2 Intended Use

2.1 Functional Description

The MOTORTECH Trend Viewer visualizes engine operating data recorded with a PowerView4 or
PowerView3 HMI module from MOTORTECH. The visualized data can be exported as a CSV file
and as an image.

2.2 Application
The MOTORTECH Trend Viewer can open files with engine operating data created by a Power-
View4 or PowerView3 HMI module from MOTORTECH.

Any use other than the one described in the operating manual shall be considered improper use
and will result in the voiding of all warranties.
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3 Installation

3.1 System Requirements
For the installation of the MOTORTECH Trend Viewer, the following minimum requirements must
be fulfilled:

— x86-compatible computer

— USBinterface 1.1 or higher

— Display with a resolution of at least 1440 x 900 pixels (WXGA+)
—  Microsoft® Windows 10, Windows 11

3.2 Installing MOTORTECH Trend Viewer
The software for installing the MOTORTECH Trend Viewer is on the storage device enclosed with
the HMI Module.

Install the MOTORTECH Trend Viewer as follows:
1. Start the installation.

— Viathe menu:
Start the file Start.exe on the storage device. Start the installation routine for the MO-
TORTECH Trend Viewer via Software -> MOTORTECH Trend Viewer -> Install MOTOR-
TECH Trend Viewer.

— Directly from the storage device:
Start the installation routine for the MOTORTECH Trend Viewer directly. On the storage
device, it is located in the sub-directory Software/MOTORTECH_Trend_Viewer and is
named, for example, as follows: MOTORTECH-Trend-Viewer-x.x.x-setup.exe
2. Run the installation.
Follow the instructions of the installation routine. Note that the license agreement terms must
be accepted before using the MOTORTECH Trend Viewer.

> You have installed the MOTORTECH Trend Viewer and can now work with recording files
of the HMI Module.
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4 Operation

4.1 User Interface
The user interface of the MOTORTECH Trend Viewer is divided into the following sections:

1 N

ORTECH Tren

2

EH

Temperature [°C]

Temperatures Recording

06 14:50:00

) o Mh;I*bD hh:mm:ss] -
Pos. Area
[ 1] Menu bar
Toolbar
Main window
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4 Operation

4.2 Menu Bar and Toolbar
The following functions are available to you via the symbols on the toolbar and the entries in the
menu bar:

Symbol Menu Function

= File -> Open Open arecording or configuration file.

:ﬂ File -> Close Close arecording file.
O File -> Export to CSV Create a CSV file from the data of an opened
» recording file.

File -> Export Plot Create an image file of the current view.

Copy the current view as an image to the clip-

board.
File -> Quit Exits MOTORTECH Trend Viewer.
Help -> Language Change the user interface language.
i Help -> Tips and Tricks Open information on how to use the MOTOR-
TECH Trend Viewer.
=4
Help -> About View information about the MOTORTECH Trend
Viewer.

Rev. 12/2023



4 Operation

4.3 Opening Files
The MOTORTECH Trend Viewer can open files with the extension .pv3 created by the HMI Module
on a USB flash drive. With the PowerView3, these files may also come from a memory card.

Recording Files
Recording files (e.g. temperatures.pv3, speed.pv3, analog_output.pv3) contain trend data that
were recorded by the HMI Module.

Configuration Files
A configuration file (configuration.pv3) is automatically created with every recording file that the
HMI Module creates. It contains general information about the recording.

4.3.1 Recording Files

The HMI Module can record data from connected MOTORTECH devices. For more information,
refer to the HMI Module's operating manual. For a detailed analysis and further processing, you
can open the recording files (e.g. temperatures.pv3, speed.pv3, analog_output.pv3) of specific
devices in the MOTORTECH Trend Viewer.

Configuration file required

i You cannot open a recording file (e. g. temperatures.pv3, speed.pv3,

analog_output.pv3) without the correct configuration file (configu-
ration.pv3). To open a recording file, the associated configuration file
NOTICE must be in the same folder as the recording file.

Do not change file names

i Renamed recording and configuration files cannot be opened.

NOTICE
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4 Operation

‘.___‘ Click on the symbol to open the desired recording file (*.pv3) in the following dialog
\\V window.
» The recording file opens in the main window of the MOTORTECH Trend Viewer.
< MOTORTECH Trend Viewer - [m] x
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The following information is provided:
— X-axis: Date (MM-DD) and time (hh:mm:ss)

— Y-axis: Measured unit and value (e.g. knocking intensity in percent, firing angle in °crankshaft,

temperature in °C or °F)

— Legend at the right window margin: Assignment of the colors to the curves

— Inthe MOTORTECH Trend Viewer, the mouse pointer is displayed as a cross. Next to it, date
(YYYY-MM-DD), time (hh:mm:ss), and value for the position of the cross are displayed.

You have the following options:

Enlarging a Section

While holding down the left mouse button, drag a rectangle over the area of the plot that you want
to enlarge. You can repeat this step several times until the desired magnification level has been
reached. By clicking the middle mouse button, you go back to the respective last step.

With a right click, you return to the initial view.
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4 Operation

Moving a Section
Hold down the Ctrl key and the left mouse button and move the view to the desired position with
the mouse.

With a right click, you return to the initial view.

Showing and Hiding Curves
At the right window margin, click on a legend entry to hide or show the associated curve. A de-
pressed legend entry means that the associated curve is hidden.

Toggling between °C and °F not possible

Temperatures are displayed in either degrees Celsius (°C) or degrees
Fahrenheit (°F). The displayed unit depends on how the HMI Module was
set during recording. It is not possible to toggle in the MOTORTECH

1

NOTICE Trend Viewer.
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4 Operation

4.3.2 Configuration Files
To obtain additional information about a recording file, open the associated configuration file
(configuration.pv3). This file is automatically created by the HMI Module with the recording file.

Do not change file names

i Renamed configuration files cannot be opened.

NOTICE

= R Click on the symbol to open the desired configuration file (configuration.pv3) in the
\N following dialog window.

» The configuration file opens in a new window.

] Configuration file selected X

You have selected a configuration file,
UL Stertof trend date: 2023-01-30 14:31:21.912

Device: MIC4

Device node ID: 30

Number of cylinders: 16

Open a data file if you want to see a plot.

Configuration files contain the following information:

— Date (YYYY-MM-DD) and time (hh:mm:ss.SSS) of the recording start
— Device

— Node ID of the device whose data was recorded

— Number of cylinders of the respective engine

Close the message with the OK button.
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4 Operation

4.4 Exporting Data
You have different options to export the data collected by the HMI Module to other programs.

Creating a CSV File

1 Click on the symbol to create a CSV file with the data of the opened recording file.
» | * SaveFile 7 x
Look in: 5y Computer o eoaABEE
W My Computer Name Size  Type Date Modified 2l
; User G G Dr?vt 24.02.2023 09:42 |
- M Drive 06.12.2022 16:21
- N: Drive 12.10.2021 14:50
-0 Drive 03.02.2023 08:36 |
- U Drive 12.06.2020 12:42 .,i
File pame: | knoding_intensity.csv | [seve

Files of type: Comma-Separated Values (*.csv)
Select CSV Format

= Cancel

(®) Time/Data Pairs () Timestamp List
T D T D: )
Ty D; Ts D: . | N D;
Ts Ds Ty Ny Dy
Ts b T b T s T | N D:

Select Time/Data Pairs to create a separate column for each curve in the CSV
file.

— Select Timestamp List to sort the values by time only.

Creating an Image

N Click on the symbol to save the current view as an image. The following formats are
@| available: bmp, jpeg, jpg, pbm, pdf, pgm, png, ppm, ps, svg, xbm, xpm.
_[= Click on the symbol to copy the current view as an image to the clipboard of your
(9 computer. You can then paste the cached image into a suitable program, usually
with Ctrl + V.
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5 Errors

5.1 Error Messages
The MOTORTECH Trend Viewer opens error messages in a pop-up window.

_"! Data file is empty x

I@ File "temperatures.pv3" does not contain any usable data.

Example

To analyze the causes of errors and to fix them, observe the hints in the error messages. Use the
OK button to confirm the error messages and to close the pop-up window.

5.2 Customer Service Information
You can reach us during our business hours by:

Phone: +49514193990

Email: service@motortech.de (technical support)
sales@motortech.de (all other matters)
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MOTORTECH GmbH
Hunaeusstrasse 5
29227 Celle
Germany

# +4951419399 0
£ sales@motortech.de
k' www.motortech.de

MOTORTECH Americas, LLC
1400 Dealers Avenue, Suite A
New Orleans, LA 70123

USA

o +1504 355 4212
B4 info@motortechamericas.com
I www.motortechamericas.com

MOTORTECH Shanghai Co., Ltd.
Room 1018 Enterprise Square,

No. 228 Meiyuan Road,

Jing’An District, 200070 Shanghai
China

o/ +86 216380 7338
B4 info@motortechshanghai.com
[»  www.motortechshanghai.com

GAS ENGINE TECHNOLOGY

www.motortech.de
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